
 Disclaimer: FHWA is committed to making its Information and Communication Technology (ICT) accessible by meeting the 
requirements of Section 508 of the Rehabilitation Act of 1973. The tools, resources, criteria and other items provided herein are for 
internal use by FHWA for ICT it procures, develops, maintains, and utilizes. The U.S. Government assumes no liability for the use by 
third parties of the information contained in this document. 

Creating Accessible Excel Files 

 

Office of Administration 
FHWA-HAD-21-005 
January 25, 2021 



 Creating Accessible Excel Files  

 



 Creating Accessible Excel Files  

FHWA-HAD-21-005 January 2021 i 

Table of Contents 

 
Table of Contents ........................................................................................................................................... i 

Properties ...................................................................................................................................................... 1 

Title and author......................................................................................................................................... 1 

Language ................................................................................................................................................... 1 

Saving ........................................................................................................................................................ 1 

Structure ....................................................................................................................................................... 1 

Logical Reading Order ............................................................................................................................... 1 

Worksheet Tabs ........................................................................................................................................ 1 

Styles ......................................................................................................................................................... 2 

Tables ........................................................................................................................................................ 2 

Other Considerations ................................................................................................................................ 2 

Text as Text ................................................................................................................................................... 2 

Background Information ............................................................................................................................... 3 

Graphics and Objects .................................................................................................................................... 3 

Sensory Characteristics ................................................................................................................................. 3 

Use of Color ............................................................................................................................................... 3 

Color contrast ........................................................................................................................................... 4 

Zoom ............................................................................................................................................................. 4 

Movement ..................................................................................................................................................... 4 

Forms and Macros ........................................................................................................................................ 4 

Embedded Media .......................................................................................................................................... 4 

Resources and References ............................................................................................................................ 4 

  



 Creating Accessible Excel Files  

FHWA-HAD-21-005 January 2021 ii 

  



 Creating Accessible Excel Files 

FHWA-HAD-21-005  January 2021 1 

Creating Accessible Excel Files  

The items discussed below help create an accessible Excel file. Content owners are expected to 
incorporate these basics into their documents.  

Using this information is a first step in making accessible files. These tips do not address every way to 
make an Excel file accessible or Section 508 conformant. See GSA’s Microsoft Excel 2016 Basic Authoring 
and Testing Guide and How to Author and Test Microsoft Excel Worksheets for Accessibility Videos for 
expanded discussion on many of the items listed below. This is not step-by-step documentation on how 
to use Excel. See https://support.microsoft.com/en-us/excel for Excel training. 

Properties 

Title and author 

Go to the “File” tab. Navigate to “Info” then “Properties." 

• Enter the full, proper document title in the “Title.” 
• Set the “Author” under “Related People” to FHWA. 

Language 

Go to the “File” tab and select “Options” then “Language.” Confirm the default human language is 
correct for the document. 

Screen readers read with an accent. For the content to be understandable to people using screen 
readers, the language needs to match the natural language of the content. 

Remediating for a document containing content in two or more languages is beyond the scope of this 
document. Avoid using content in a language other than the default. 

Saving 

Save as a .xlsx to retain accessibility features. Go to the “File” tab and select “Excel Workbook (*.xlsx)” 
from the “Save As” drop down. Contact the FHWA Section 508 Coordination Team if saving the file as 
anything but an “*.xlsx” file, e.g., an “Excel Macro-Enabled Workbook (*.xlsm).” 

Structure 

Logical Reading Order 

Ensure the reading order of the content is logical. Typically, it is left to right, top to bottom, starting with 
cell A1.  

Worksheet Tabs 

Give each worksheet tab a descriptive and unique name. 

https://www.section508.gov/sites/default/files/MS%20Excel%202016%20Basic%20Authoring%20and%20Testing%20Guide-AED%20COP.docx
https://www.section508.gov/sites/default/files/MS%20Excel%202016%20Basic%20Authoring%20and%20Testing%20Guide-AED%20COP.docx
https://www.section508.gov/create/spreadsheets/training-videos
https://support.microsoft.com/en-us/excel
mailto:FHWASection508@dot.gov
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Styles 

Use styles to give the content structure and to indicate the cell’s purpose. From the “Home” tab, 
navigate to the “Styles” group. Select a style for its function not for its format. Once selected, update the 
format. Use “Styles” Headings in hierarchal order. 

Tables 

Insert a table using the “Table” option found in the “Tables” group of the “Insert” tab. For an existing 
table not created using the “Table” option, highlight all the table content. Select the “Table” option 
using the same steps as inserting a table. 

Once the “Table” is set, go to the “Design” tab found under the “Table Tools” tab. Navigate to the 
“Properties” group. In the “Table Name:” field, give the table a descriptive, unique name. 

Next, navigate to the “Table Style Options” of the “Table Tools” tab “Design” tab. Ensure Header row 
and First column (if needed, it usually is) are checked. 

For each table, ensure: 
• Each table has a descriptive caption. 
• Column and row headers contain descriptive content. 
• There are no row or column spans. 
• There is only one level of row and column headers. 
• There are no nested tables. 
• Data and headers are in separate cells. 

Other Considerations  

• Links. Ensure the linked words are unique and descriptive of the link destination or the purpose 
of the link is discernable from surrounding text. Do not use “click here,” “read more,” etc. 

• Symbols. Insert symbols as proper symbols using the “Symbol” option found in the “Symbols” 
group of the “Insert” tab. For instance, do not create a ≤ or ≥ by underlining a < or >. Also do not 
create a ˚ by making the letter o superscript. Avoid adding them as an image. 

Text as Text 

Render text as text, not an image. This includes content copied from another source. 

This does not apply to:  

• Logos. 
• Incidental text. Incidental text includes purely decorative images or parts of an image that 

contain significant other visual content such as a sign in the background of a photograph. 
• Images replacing text to maintain a certain look such as an infographic, flowchart, or equation. 
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Background Information 

Background information includes watermarks and content in headers or footers that may not be 
available to assistive technologies. Ensure vital information is duplicated in the first cell of the 
worksheet. 

Graphics and Objects 

• When a graphic is created using multiple individual graphics, “Group” them to create a single 
graphic. “Group” by selecting all the parts of the individual graphics. Then from the “Format” 
tab under “Picture Tools” tab or “Drawing Tools” tab, select “Group” from the “Group” drop 
down in the “Arrange” group. 

• Provide a description (alt text) for all graphics conveying meaningful information. This 
description is an equivalent of the graphics, do not add extra information or skip anything 
relevant. 

• Only graphics providing meaningful information need alt text. Do not add alt text to decorative 
images. If available, select the “Make as decorative” check box on the Alt Text dialog box. If it is 
not available, add “” or ‘null’ to the “Description” field. 

• Add the alt text by selecting the image. Then go to the “Format” tab on the “Picture Tools” tab. 
Select the “dialog box launcher” in the “Picture Styles” group of this tab. The “dialog box 
launcher” is the small, downward pointing arrow found at the bottom right of a group. 
Alternatively, open the “dialog box launcher” by selecting “Alt then JP then O.” This opens the 
“Format Picture” task pane. Navigate to the “Size and Properties” icon then select “Alt Text.” 
Add the alt text to the “Description” field. The “Title” field does not need to be completed for 
Section 508 conformance. 

• Describe the meaning of the image fully in as few words as possible. Ensure the alt text does not 
repeat the caption or other surrounding text. Do not start alt text with “this is an image of” since 
that is assumed. 

• Images, objects, shapes, charts, and other non-text elements that are not anchored to a cell are 
inaccessible. Provide a text description in a cell nearby or list all in an appendix. 

• Provide an alternate keystroke combination for buttons used to perform an action, e.g., clear 
table, update results. Ensure the keystroke combination does not interfere with standard Excel 
or assistive technologies keystrokes. Provide a description of the keystroke close to the button. 

• The document is free of text boxes. 

Sensory Characteristics 

Avoid references to shape, size sound, color, or location. 

Use of Color 

Information cannot be conveyed by color alone. This applies to content including text, links, and 
graphs/charts. 
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• Text: When changing the font color or the background color to convey information, such as 
using a color-coded table, indicating updates are in a certain color font, or highlighting content, 
there needs to be another way to uniquely, visually convey this information  

• Graphs/Charts: If the document has charts or graphs, ensure that each line or segment has a 
non-color visual indicator. For line graphs, the visual indicator can be a unique marker, line style, 
or name of the line pointing to the line. For charts, the visual indicator can be unique pattern on 
each segment or the name of each segment near the segment. Note: putting the values of a 
point on a line or of a segment does not satisfy this criterion. 

• Links: It is recommended to reserve underlines for only links. If not, ensure the links pass 
minimum contrast against both the background and surrounding font and have another visual 
indicator available when the link is selected. 

Color contrast 

All text color combinations meet WCAG 2.0 AA minimum color contrast requirements. This includes 
images that are mainly text, such as an infographic. This does not apply to logos or images where the 
text is incidental to a graphic.  

Zoom 

Except for captions and images of text, text is resizable and readable when zoomed to 200% without 
assistive technology. 

Movement 

The document is free from any content that blinks or flashes.  

Forms and Macros 

Forms and documents with macros are beyond the scope of this documentation. Contact the Agency 
Section 508 Coordinator if the Excel file contains forms and/or macros. 

Embedded Media 

See “Creating Section 508 Multimedia.” 

Resources and References 

• https://www.section508.gov/create/spreadsheets.  
• https://www.hhs.gov/sites/default/files/hhs-508-excel-checklist.xlsx. 

mailto:FHWASection508@dot.gov
mailto:FHWASection508@dot.gov
https://www.fhwa.dot.gov/508/docs/had21008.pdf
https://www.section508.gov/create/spreadsheets
https://www.hhs.gov/sites/default/files/hhs-508-excel-checklist.xlsx

	Table of Contents
	Properties
	Title and author
	Language
	Saving

	Structure
	Logical Reading Order
	Worksheet Tabs
	Styles
	Tables
	Other Considerations

	Text as Text
	Background Information
	Graphics and Objects
	Sensory Characteristics
	Use of Color
	Color contrast

	Zoom
	Movement
	Forms and Macros
	Embedded Media
	Resources and References

